opencv-contriv-3.4.1.15 python 패키지 설치

파이썬으로 영상처리를 해보고자 관련 책도 샀는데, OpenCV 상용 라이브러리가 포함되어 있는 3.4.1.15 버전을 추천하고 있었다. 그래서 설치를 하려고 아래 명령어를 입력했다.

pip install opencv-python-contriv==3.4.1.15

그랬더니, 3.4.1.15 버전이 패키지 저장소에 없다고 한다. 그래서 pip opencv 3.4.1.15로 검색해서 나오는 아래 페이지에서 직접 whl 파일을 다운받았다.

https://pypi.org/project/opencv-contrib-python/3.4.1.15/#files

그런데… pip install (파일명) 을 실행을 하자, 지원되지 않는 플랫폼 오류가 나더라. 내 환경은 파이썬 3.8 64bit였고, 인텔 프로세서를 쓰고 있는데 인텔이나 amd나 64bit 명령어는 호환되니까 그냥 64비트 버전을 다운받아서 설치하려 한 것이다.

더 검색을 해 보자, 파일명 내의 cp34 같은 문자열이 의미하는 게 CPython 3.4버전이라는 것이다. 이를 알아내고, 가장 최신인 파이썬 버전을 지원하는 cp36 amd64 버전 휠 파일을 다운받았는데, 마찬가지로 안 된다.

결국엔 파이썬 3.8을 32비트로 설치하고 나니 OpenCV도 설치가 가능했다.

파이썬 3.6.8 for Windows 다운로드 주소는 아래와 같다. 릴리즈별로 플랫폼이 달라서 찾는 것도 나름 일이더라.

https://www.python.org/downloads/release/python-368/

댓글 남기기

이메일은 공개되지 않습니다. 필수 입력창은 * 로 표시되어 있습니다